ZOJ 3960:What Kind of Friends Are You?

What Kind of Friends Are You?

Time Limit: 1 Second Memory Limit: 65536 KB

Japari Park is a large zoo home to extant species, endangered species, extinct species, cryptids and some legendary creatures. Due to a mysterious substance known as Sandstar, all the animals have become anthropomorphized into girls known as Friends.

Kaban is a young girl who finds herself in Japari Park with no memory of who she was or where she came from. Shy yet resourceful, she travels through Japari Park along with Serval to find out her identity while encountering more Friends along the way, and eventually discovers that she is a human.

However, Kaban soon finds that it’s also important to identify other Friends. Her friend, Serval, enlightens Kaban that she can use some questions whose expected answers are either “yes” or “no” to identitfy a kind of Friends.

To be more specific, there are n Friends need to be identified. Kaban will ask each of them q same questions and collect their answers. For each question, she also gets a full list of animals’ names that will give a “yes” answer to that question (and those animals who are not in the list will give a “no” answer to that question), so it’s possible to determine the name of a Friends by combining the answers and the lists together.

But the work is too heavy for Kaban. Can you help her to finish it?

Input

There are multiple test cases. The first line of the input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains two integers n (1 ≤ n ≤ 100) and q (1 ≤ q ≤ 21), indicating the number of Friends need to be identified and the number of questions.

The next line contains an integer c (1 ≤ c ≤ 200) followed by c strings p1, p2, … , pc (1 ≤ |pi| ≤ 20), indicating all known names of Friends.

For the next q lines, the i-th line contains an integer mi (0 ≤ mi ≤ c) followed by mi strings si, 1, si, 2, … , si, mi (1 ≤ |si, j| ≤ 20), indicating the number of Friends and their names, who will give a “yes” answer to the i-th question. It’s guaranteed that all the names appear in the known names of Friends.

For the following n lines, the i-th line contains q integers ai, 1, ai, 2, … , ai, q (0 ≤ ai, j ≤ 1), indicating the answer (0 means “no”, and 1 means “yes”) to the j-th question given by the i-th Friends need to be identified.

It’s guaranteed that all the names in the input consist of only uppercase and lowercase English letters.

Output

For each test case output n lines. If Kaban can determine the name of the i-th Friends need to be identified, print the name on the i-th line. Otherwise, print “Let’s go to the library!!” (without quotes) on the i-th line instead.

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
2
3 4
5 Serval Raccoon Fennec Alpaca Moose
4 Serval Raccoon Alpaca Moose
1 Serval
1 Fennec
1 Serval
1 1 0 1
0 0 0 0
1 0 0 0
5 5
11 A B C D E F G H I J K
3 A B K
4 A B D E
5 A B K D E
10 A B K D E F G H I J
4 B D E K
0 0 1 1 1
1 0 1 0 1
1 1 1 1 1
0 0 1 0 1
1 0 1 1 1

Sample Output

1
2
3
4
5
6
7
8
Serval
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
B
Let's go to the library!!
K

Hint

The explanation for the first sample test case is given as follows:

As Serval is the only known animal who gives a “yes” answer to the 1st, 2nd and 4th question, and gives a “no” answer to the 3rd question, we output “Serval” (without quotes) on the first line.

As no animal is known to give a “no” answer to all the questions, we output “Let’s go to the library!!” (without quotes) on the second line.

Both Alpaca and Moose give a “yes” answer to the 1st question, and a “no” answer to the 2nd, 3rd and 4th question. So we can’t determine the name of the third Friends need to be identified, and output “Let’s go to the library!!” (without quotes) on the third line.

题意

先输入一个t,表示接下来有t组数据;
每组数据有第一行有两个数:n和q;表示这个人有n个朋友,有q次询问;
第二行输入一个数c,表示将输入c个朋友的名字,接着输入c个名字;
第三行到接下来的q-1行;输入要描述的名字的个数和这些名字;
完了之后接下来n行输入这n人对这q个信息的回答,1表示有这个人的名字,0表示没有这个人的名字;如果通过这个人的回答能够确定他是谁,那就输出它的名字,如果不能,就输出Let's go to the library!!

Solve

基础思路:
对于每个询问,如果回答是0,则将这些名字标记为-1,否则将名字出现的次数加一,如果名字已经标记为-1,并且自此回答是1,那么一定是矛盾的,所以对于已经标记为-1的名字,次数不要加一。
实现:
一开始用的map直接存每个名字,map<string,int>mp这样进行计数,但是不知道为什么T掉了(可能时间没有算对)。
因为题目第一行给出了所有可能出现的名字,所以可以用第一行名字出现的位置来代替名字,这样,可以用一个数组进行上述map的操作,最后运行时间为60ms

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
/*************************************************************************

> Author: WZY
> School: HPU
> Created Time: 2019-04-12 10:02:59

************************************************************************/
#include <bits/stdc++.h>
#define ll long long
#define ull unsigned long long
#define ms(a,b) memset(a,b,sizeof(a))
#define INF 0x7f7f7f7f
const int maxn=1e6+10;
const int mod=1e9+7;
using namespace std;
int vis[300];
inline void Debug(){cerr<<'\n';}
template<class FIRST, class... REST>void Debug(FIRST arg, REST... rest){
cerr<<arg<<"";Debug(rest...);}
int main(int argc, char const *argv[])
{
ios::sync_with_stdio(false);
cin.tie(0);
int t;
cin>>t;
int n,m;
while(t--)
{
vector<int >v[210];
int num;
string name;
string s[210];
cin>>n>>m;
vector<int>ve;
map<string,int>mp;
int x;
cin>>x;
for(register int i=0;i<x;i++)
{
cin>>s[i];
mp[s[i]]=i;
ve.push_back(i);
}
for(register int i=0;i<m;i++)
{
cin>>num;
for(register int k=0;k<num;k++)
{
cin>>name;
v[i].push_back(mp[name]);
}
}
int id;
while(n--)
{
int res=0;
ms(vis,0);
for(register int i=0;i<m;i++)
{
cin>>id;
res+=id;
if(!id)
{
int sz=v[i].size();
for(register int j=0;j<sz;j++)
{
vis[v[i][j]]=-1;
}
}
else
{
int sz=v[i].size();
for(register int j=0;j<sz;j++)
{
if(vis[v[i][j]]==-1)
continue;
else
vis[v[i][j]]++;
}
}
}
int l=ve.size();
int ans;
int flag=0;
for(register int i=0;i<l;i++)
{
if(!flag&&vis[ve[i]]==res)
{
flag++;
ans=ve[i];
}
else if(flag&&vis[ve[i]]==res)
{
flag++;
break;
}
}
if(flag==1)
cout<<s[ans]<<"\n";
else
cout<<"Let's go to the library!!\n";
}
}
return 0;
}

本文标题:ZOJ 3960:What Kind of Friends Are You?

文章作者:执念

发布时间:2019年04月21日 - 21:04

最后更新:2019年04月21日 - 21:04

原始链接:https://blog.wzy1999.wang/solve/zoj3960/

许可协议: 署名-非商业性使用-禁止演绎 4.0 国际 转载请保留原文链接及作者。

-------------本文结束感谢您的阅读-------------
0%