ZOJ 3778:Talented Chef(贪心?思维)

Talented Chef

Time Limit: 2 Seconds Memory Limit: 65536 KB

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare $N$ dishes for the dinner. The $i$-th dish contains $A_i$ steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most $M$ different dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer $T$ indicating the number of test cases. For each test case:
The first line contains two integers $N$ and $M$ $(1 <= N, M <= 40000)$. The second line contains $N$ integers $A_i$ $(1 <= Ai <= 40000)$.

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input

1
2
3
4
5
2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

1
2
3
10

题意

有$n$个菜,做每个菜需要$a_i$步,每次最多可以做$m$个菜,求做完这$n$个菜最少需要多少时间

Solve

先提供一个超时的思路:将$n$个菜按照$a_i$降序排序,排序后每次取出前$m$个菜,然后让这$m$个菜一直减到取出的最小的$a_i$小于未取出的$n-m$个菜的最大的$a_i$,然后将减少后的不等于$0$的$a_i$放入序列中,重复上述操作,直到$n$个数全部为$0$。
时间复杂度大概为$O(n\times m)$

不超时的算法
将所有的$a_i$加起来,$sum=\sum a_i$,然后$sum$除以$m$向上取整。
但是只有这样是不正确的:如果出现了$\lceil \dfrac {sum}{m}\rceil <max(a_i)$的情况,那么所需的时间一定不会小于$a_i$中的最大值,所以我们需要比较$\lceil \dfrac {sum}{m}\rceil$和$max(a_i)$的值
证明:点这里吧,不太会证明。程序是照着超时的思路对拍出来的

Code

超时代码在最后
AC代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include <bits/stdc++.h>
#define ll long long
#define ull unsigned long long
#define ms(a,b) memset(a,b,sizeof(a))
const int inf=(1<<30);
const ll INF=(1LL*1<<60);
const int maxn=1e6+10;
const int mod=1e9+7;
const int maxm=1e3+10;
using namespace std;
int main(int argc, char const *argv[])
{
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
freopen("out1.txt", "w", stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
int t;
cin>>t;
while(t--)
{
int n,m;
ll x;
cin>>n>>m;
ll sum=0;
ll maxx=0;
for(int i=0;i<n;i++)
{
cin>>x;
maxx=max(maxx,x);
sum+=x;
}
ll _=(sum - 1)/(1LL*m)+1;
cout<<max(maxx,_)<<endl;
}
return 0;
}

超时代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
/*************************************************************************

> Author: WZY
> School: HPU
> Created Time: 2019-04-20 09:07:07

************************************************************************/
#include<bits/stdc++.h>
using namespace std;
const int maxn = 4e4 + 10;
int a[maxn];
int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
freopen("out2.txt", "w", stdout);
#endif
int t;
int x;
scanf("%d",&t);
while (t --)
{
int ans=0;
int n,m;
priority_queue<int,vector<int>,less<int> > que;
scanf("%d %d",&n,&m);
for (int i = 0;i < n;i ++)
{
scanf("%d",&x);
que.push(x);
}
while(!que.empty())
{
int cnt=0;
int minn;
for(int i=0;i<m;i++)
{
minn=que.top();
que.pop();
a[cnt++]=minn;
if(que.empty())
break;
}
int maxx;
if(que.empty())
maxx=0;
else
maxx=que.top();
int __=max(1,minn-maxx);
ans+=max(1,minn-maxx);
for(int i=0;i<cnt;i++)
{
a[i]=max(a[i]-__,0);
if(a[i])
que.push(a[i]);
}
}
printf("%d\n",ans);
}
return 0;
}

本文标题:ZOJ 3778:Talented Chef(贪心?思维)

文章作者:执念

发布时间:2019年04月21日 - 21:04

最后更新:2019年04月21日 - 21:04

原始链接:https://blog.wzy1999.wang/solve/zoj3778/

许可协议: 署名-非商业性使用-禁止演绎 4.0 国际 转载请保留原文链接及作者。

-------------本文结束感谢您的阅读-------------
0%